VoyForums
[ Show ]
Support VoyForums
[ Shrink ]
VoyForums Announcement: Programming and providing support for this service has been a labor of love since 1997. We are one of the few services online who values our users' privacy, and have never sold your information. We have even fought hard to defend your privacy in legal cases; however, we've done it with almost no financial support -- paying out of pocket to continue providing the service. Due to the issues imposed on us by advertisers, we also stopped hosting most ads on the forums many years ago. We hope you appreciate our efforts.

Show your support by donating any amount. (Note: We are still technically a for-profit company, so your contribution is not tax-deductible.) PayPal Acct: Feedback:

Donate to VoyForums (PayPal):

Login ] [ Contact Forum Admin ] [ Main index ] [ Post a new message ] [ Search | Check update time | Archives: 1[2]34 ]
Subject: Jabasco water pump


Author:
Aubrey
[ Next Thread | Previous Thread | Next Message | Previous Message ]
Date Posted: 23:32:53 26/01/2011 Wed

Hi, I am currently re-building my 16oo x flow engine following a full rebuild and have noticed on examination of the water pump the impellor is split and the rubber seal looks like it has had it. The only numbers I can find on it are either 9900 or 0066 it`s a jabasco bronze pump. Can anyone give me some advice on if and where parts can be obtained, Thanks, Aubrey.

[ Next Thread | Previous Thread | Next Message | Previous Message ]

Replies:
Subject Author Date
Re: Jabasco water pumpIan10:45:24 27/01/2011 Thu


[ Contact Forum Admin ]


Forum timezone: GMT+0
VF Version: 3.00b, ConfDB:
Before posting please read our privacy policy.
VoyForums(tm) is a Free Service from Voyager Info-Systems.
Copyright © 1998-2019 Voyager Info-Systems. All Rights Reserved.