VoyForums

Login ] [ Contact Forum Admin ] [ Main index ] [ Post a new message ] [ Search | Check update time | Archives: 1234 ]
Subject: Re: Ford 1500 engine


Author:
Mike Thompson
[ Next Thread | Previous Thread | Next Message | Previous Message ]
Date Posted: 10:33:46 15/07/2013 Mon
In reply to: Roger 's message, "Ford 1500 engine" on 18:58:20 18/06/2013 Tue

Hi Roger,

I don't have specific knowledge of your engine but based on your description my first port of call would be the thermostat. If it's one of the old bellows types the chances are that the bellows have failed due to work-hardening. Even the wax-element types can begin to not open fully with age. Your white plugs are probably indicative of overheating as you suspected.

[ Next Thread | Previous Thread | Next Message | Previous Message ]

Replies:
Subject Author Date
Re: Ford 1500 enginesteve jones20:42:44 18/08/2013 Sun


Login ] Create Account Not required to post.
Post a public reply to this message | Go post a new public message
Note: This forum is moderated -- new posts are not visible until approved.
* HTML allowed in marked fields.
Message subject (required):

Name (required):

  Expression (Optional mood/title along with your name) Examples: (happy, sad, The Joyful, etc.) help)

  E-mail address (required):

* Type your message here:


Note: This forum is moderated -- new posts are not visible until approved.

Notice: Copies of your message may remain on this and other systems on internet. Please be respectful.

[ Contact Forum Admin ]


Forum timezone: GMT+0
VF Version: 3.00b, ConfDB:
Before posting please read our privacy policy.
VoyForums(tm) is a Free Service from Voyager Info-Systems.
Copyright © 1998-2017 Voyager Info-Systems. All Rights Reserved.