VoyForums
[ Show ]
Support VoyForums
[ Shrink ]
VoyForums Announcement: Programming and providing support for this service has been a labor of love since 1997. We are one of the few services online who values our users' privacy, and have never sold your information. We have even fought hard to defend your privacy in legal cases; however, we've done it with almost no financial support -- paying out of pocket to continue providing the service. Due to the issues imposed on us by advertisers, we also stopped hosting most ads on the forums many years ago. We hope you appreciate our efforts.

Show your support by donating any amount. (Note: We are still technically a for-profit company, so your contribution is not tax-deductible.) PayPal Acct: Feedback:

Donate to VoyForums (PayPal):

Login ] [ Contact Forum Admin ] [ Main index ] [ Post a new message ] [ Search | Check update time | Archives: 12 ]


[ Next Thread | Previous Thread | Next Message | Previous Message ]

Date Posted: 05:23:06 09/20/02 Fri
Author: Lisa
Subject: Broken Vectrex in Need

Hi, I have a vectrex which is not working, and I cannot find anyone in South Australia who knows how to fix them. Any Ideas out there? The problem is there is no picture, you can hear minestorm and move the controlls and its working but cannot see it. Have checked dimmer control, thats not it, I need help as I have lots of game and two controllers but NEED the console back up and running !!

[ Next Thread | Previous Thread | Next Message | Previous Message ]


Replies:

[> Re: Broken Vectrex in Need -- max, 06:39:37 04/28/03 Mon

I am in the same situation (only I am in Western Australia!)
I can hear the unit playing mine storm and it responds to the contols (at least it sounds like it does!) but I get nothing on the screen. If I turn the brightness up full, I can see some white dots on the screen, all within 2 or 3 centimetres of each other, in an almost horizontal line about 1/3 of the screen height from the top, and 1/4 of the screen width from the right hand side. The dots move slightly along with the gameplay (ie as the mines are being distributed at the start of a level, but not really noticably after that).

I saw an entry in the vectrex faq (<a rel=nofollow target=_blank href="http://www.roachnest.com/vectrex.html)">http://www.roachnest.com/vectrex.html)</a> which mentioned something similar, but I dont want to solder things unless I'm sure it will fix the problem.

Its a dusty old unit, which I have attempted to clean, and prior to this was not in use for about 10 years. Is it possible it just needs some 'warming up' time? Has anyone had anything similar happen and found a solution?

Please let me know - I'm dying to play the games I loved when I was 10!

Max

>Hi, I have a vectrex which is not working, and I
>cannot find anyone in South Australia who knows how to
>fix them. Any Ideas out there? The problem is there is
>no picture, you can hear minestorm and move the
>controlls and its working but cannot see it. Have
>checked dimmer control, thats not it, I need help as I
>have lots of game and two controllers but NEED the
>console back up and running !!

[ Post a Reply to This Message ]
[ Edit | View ]



Post a message:
This forum requires an account to post.
[ Create Account ]
[ Login ]
[ Contact Forum Admin ]

Forum timezone: GMT-8
VF Version: 3.00b, ConfDB:
Before posting please read our privacy policy.
VoyForums(tm) is a Free Service from Voyager Info-Systems.
Copyright © 1998-2019 Voyager Info-Systems. All Rights Reserved.