VoyForums
[ Show ]
Support VoyForums
[ Shrink ]
VoyForums Announcement: Programming and providing support for this service has been a labor of love since 1997. We are one of the few services online who values our users' privacy, and have never sold your information. We have even fought hard to defend your privacy in legal cases; however, we've done it with almost no financial support -- paying out of pocket to continue providing the service. Due to the issues imposed on us by advertisers, we also stopped hosting most ads on the forums many years ago. We hope you appreciate our efforts.

Show your support by donating any amount. (Note: We are still technically a for-profit company, so your contribution is not tax-deductible.) PayPal Acct: Feedback:

Donate to VoyForums (PayPal):

Login ] [ Contact Forum Admin ] [ Main index ] [ Post a new message ] [ Search | Check update time | Archives: 1234567[8]910 ]


[ Next Thread | Previous Thread | Next Message | Previous Message ]

Date Posted: 21:32:06 05/03/01 Thu
Author: Wen
Subject: Re: Problem in using TGraphicClass
In reply to: Michel 's message, "Re: Problem in using TGraphicClass" on 20:05:57 05/03/01 Thu

Yes, if I just modify the declaration of GraphicClass from TGraphicClass to TDibGraphicClass and keep all else intack. The code will work correctly. Moreover, as I have said, GraphicClass.Create will not bring me to the create method
of TJpegGraphic, nor TDibGraphic, even nor TGraphic!!!.
This may be a bug in Delphi. However, TPicture with registration of TJpegGraphic will work all right. Although
it also uses TGraphicClass as its class reference!


>
>Hi Wen,
>
>The structure of the code looks fine. The first thing
>I would try is replacing the types TGraphicClass and
>TGraphic with TDibGraphicClass and TDibGraphic
>respectively.
>
>I wonder if Delphi is not confused with the run-time
>type information when handling class variables. If you
>trace into GraphicClass.Create, does the debugger
>bring you to an Envision unit?
>
>Best regards,
>
>Michel
>
>
>
>
>
>>I use TJpegGraphic as following:
>>var
>> GraphicClass: TGraphicClass;
>> Graphic: TGraphic:
>>begin
>> GraphicClass := TJpegGraphic;
>> Graphic := GraphicClass.Create;
>> Graphic.LoadFromFile('mypicture.jpg');
>>//Access Violation every time I execute here
>>end;
>>In addition, I found in the second statement
>>GraphicClass.Create does not call the
>>
>>TJpegGraphic.Create method.
>>
>>However, if modified the above code to:
>>begin
>> Graphic := TJpegGraphic.Create;
>> Graphic.LoadFromFile('mypicture.abc');
>>end;
>>
>>all work correctly, Can anyone tell me what wrong with
>>the first code sippet.

[ Next Thread | Previous Thread | Next Message | Previous Message ]


Replies:


[ Contact Forum Admin ]


Forum timezone: GMT-5
VF Version: 3.00b, ConfDB:
Before posting please read our privacy policy.
VoyForums(tm) is a Free Service from Voyager Info-Systems.
Copyright © 1998-2019 Voyager Info-Systems. All Rights Reserved.