VoyForums

Login ] [ Contact Forum Admin ] [ Main index ] [ Post a new message ] [ Search | Check update time | Archives: 123456[7]8910 ]


[ Next Thread | Previous Thread | Next Message | Previous Message ]

Date Posted: 06:34:01 08/31/01 Fri
Author: Michel
Subject: Re: CreateDibSection failed error
In reply to: Greg Pencheff 's message, "Re: CreateDibSection failed error" on 08:21:38 08/30/01 Thu


Hi Greg,

LoadFromFile should not cause this. I will do more testing on this. My primary platform is W2K so I have not come across this. I remember doing a test similar to loading many consecutive images. I will try again on Windows 98 with images about that size.

Could you also try simply loading images consecutively in the Demo.EXE program and see if the problem occurs.

Best regards,

Michel


>Michael,
>
>All images are single page b/w TIFs, approximately
>2500 x 3200 pix. The problem only occurs after
>loading a number of consecutive images. I use one
>TImageScrollbox component and repeatedly call
>LoadFromFile(FileName.tif,1). Is there some
>additional step I should be using to clear memory/free
>resources between calls to LoadFromFile?
>
>Greg
>
>>
>>Hi Greg,
>>
>>I have seen this happen when relatively large images.
>>On Win2K the error is much less frequent.
>>
>>In your case, does it happen after loading a large
>>images (ie, a few thousand x a few thousand pixels) or
>>simply after loading consecutive images?
>>
>>I have checked for resource leaks but have not found
>>any with MemProof.
>>
>>Best regards,
>>
>>Michel

[ Next Thread | Previous Thread | Next Message | Previous Message ]

[ Contact Forum Admin ]


Forum timezone: GMT-5
VF Version: 3.00b, ConfDB:
Before posting please read our privacy policy.
VoyForums(tm) is a Free Service from Voyager Info-Systems.
Copyright © 1998-2019 Voyager Info-Systems. All Rights Reserved.